A good hex editor is an essential tool for anyone in the computer security field. In fact, it’s quite useful even if you aren’t in the computer security field… Hex editors allow you to view and edit the binary content of a file at the byte level by interpreting the data in easily-readable hexadecimal. This is beneficial for two reasons: First, binary files often contain data that looks like gibberish when interpreted as plain text. This makes it very hard to see and understand the data contained within these files using high level applications such as a simple text editor. Second, it is often difficult (if not impossible) to modify such data using such high level applications without breaking something[…]

We talk a lot about how SSL is useful, but how exactly does it work? Most systems today use SSL v3/TLS v1 rather than “SSL”, and the nitty gritty details are found in RFC 2246. However, that’s only part of what goes on, and certificate validation and path building (RFC 4158) and X.509 certificates (RFC 5280) are also important. This post is only concerned with the SSL/TLS protocol itself, and when the other RFCs are needed “magic happens.” If you’re interested, I highly recommend reading through the RFCs. I do assume that you’ve got basic certificate and PKI knowledge while reading this. If you don’t, Mike wrote a great series on it.

Pinging is an easy way to determine if communication is possible between two hosts, but sometimes you need more information than an ICMP echo request can provide. hping is a nifty command-line tool that allows you to use different protocols and the features of those protocols to test how a host will respond to different scenarios. It can be a strong ally for network analysts who want to find all the holes in their network before the bad guys do.

I’ve downloaded (but not yet installed) the Windows 7 release candidate, and I’ve been perusing the security features they’ve added to the OS. Two things that have caught my eye are the new BitLocker to Go feature and AppLocker. BitLocker to Go adds the capability to encrypt a USB disk drive through the BitLocker interface, which will protect any sensitive data stored on the drive from falling into the wrong hands. (Of course, the data protection is only as strong as the password you use, so remember not to make it something easily figured out by someone who nabs your device.) Data loss via portable devices has always been problematic – this is a pretty common sense way to at[…]

Let’s face it. Virtualization is everywhere in businesses today. There probably isn’t an IT admin out there that doesn’t swear by it. The sheer number of benefits it adds to the IT departments with its reduced resources, better energy savings, easier administration, etc. It’s also nothing new really. It’s been around for quite some time now, but it has usually been limited to the IT departments, developers, system testers, or the other elite geeks. It hasn’t really been a product for mass consumption – until now very soon. Anyone who hasn’t been hiding under a rock for the past few weeks has probably heard about Microsoft’s new OS, Windows 7, and how it’s incorporated a built-in Windows XP virtualization. It[…]

If you’ve ever wanted to see exactly what your web browser was sending and receiving, there are plenty of programs out there that can help you out. The reasons you might want to see that kind of information may vary: maybe you’re debugging an in-browser flash app; or perhaps you want to see what HTTP headers a web server responds with; or maybe you even want to try some fuzzing to test the security of a web app. In any case, having the ability to pull back the curtain and see what your browser is doing behind the scenes can be useful. One particular program that does this well is Fiddler. It acts as a local proxy– simply point your[…]